Unable to edit my bibtex file that I used before vers. 5.1

In earlier versions of JabRef I could easily edit and use my BibTex entries in my latex files. Now, there are fields that are incorrectly named and ignore anything I try to enter. I have tried to fix things but it seems hopless. Why is this new version causing so many problems for me? Earlier versions were great – easy to use and reliable. It is now almost useless to me. Perhaps you can prepare an older version that will accept my older BibTex files. Before you ask for donations I suggest that you take care of fixing the problems that you have introduced in these “JabRef updates”, or perhaps use/hire some programmers that understand how JabRef should work with BibTex files. It took me over 10 years to create my BibTex files that are now unacceptable to the latest version – what a waste :-1:

Also, where can I get a sample of a BibTex file that actually works with vers. 5.1? This file should contain a good coverage of the different types of references that this version should handle. Your test suite would probably be sufficient! I have (tried to do so) attached 3 PNG files that illustrate just one of the problems that I have experienced with 5.1. Note, no matter what I enter in the Number Field it is never shown in the display of the reference; but, it is shown in the BibTex Source Field.JabRef_5.1_NumberField_2020-11-06|690x345
And I could only attach one of the 3 files that could be useful for understanding this problem :slightly_frowning_face:

First of all thanks for using JabRef and sorry for the inconvenice you encountered.
Please keep in mind that all developers of JabRef are contributing in their free time for JabRef and we don’t get paid for development.
Our many thankful users that have been and are using JabRef and are also donating help us to keep us motivated. JabRef is and will continue to be OpenSource and free software.

Actually, your problem has nothing to do with the bibtex format or an older version of JabRef.
You are refering to the preview style.The preview style can be customized by the user to adjust which fields are shown. In your case you would need to modify the line where you want to show the field.

Go to Preferences -> Entry preview -> Preview (or Customized Preview style) -> Edit:
Replace the line that starts with:
\begin{year}

and replace it with:

\begin{year}<b>\year</b>\end{year}\begin{volume}<i>, \volume</i>\end{volume}, \begin{number}<i>,\number</i>\end{number} \begin{pages}, \format[FormatPagesForHTML]{\pages} \end{pages}

and your number field will show up next/after volume. For more information: https://docs.jabref.org/setup/preview

Best regards and stay healhty during this troubling times.
Christoph

Dear Birdy,

Thank you so much for your great suggestion. I am very unsure how “hire” works. Can you explain it to me please? You can also send me a private message.

May we work together in this? A good start are the files in https://github.com/JabRef/jabref/tree/master/src/test/resources/testbib . The file https://github.com/JabRef/jabref/blob/master/src/test/resources/testbib/testjabref.bib should be a good start.

I am too dumb to see all three PNGs. I only see one.

May I ask for support of you? I am a bit disabled in understanding your issues. Would you mind to write one post per issue? Then, I can think of it. Handling three different issues in parallel is really to much for me.

I have asked my family if it is OK to spend some of my family time to your issues. They very like “Birdy”. Thus, they allowed me to so. They also support me to ask for some other presentation of the issue.

Thank you so much for your understanding.

1 Like

Ok Oliver,
Thank you for the testjabref.bib – I will test it myself.
I would be glad to help you; but my time available for help with JabRef is limited.

I am now entering manually some references that I need for some manuscripts that I am working with — this takes a lot of my time 🙁

Is it possible that I could install an older version of JabRef and use it with some older *.bib files that was compatible with these older *.bib files?

När du har kontakt med oss på Uppsala universitet med e-post så innebär det att vi behandlar dina personuppgifter. För att läsa mer om hur vi gör det kan du läsa här: http://www.uu.se/om-uu/dataskydd-personuppgifter/ E-mailing Uppsala University means that we will process your personal data. For more information on how this is performed, please read here: http://www.uu.se/en/about-uu/data-protection-policy

I have installed two different versions of JabRef (4.3.1 and 5.1). I already have the latest SIAM guide to using Siam’s LaTeX Style (docsiamart.tex) and reference.bib which you can get at https://archive.siam.org/journals/auth-info.php . I loaded reference.bib into both JabRef versions and looked at how the same entries were displayed. I suggest that you do the same and then get back to me on what differences you observe. Hopefully you can provide some details about why they are different. You might also compile docsiamart.tex (e.g. with TexMaker) with the reference.bib in the same folder, and see how it looks in practice (esp. the URL references). It might also be useful to look at: https://archive.siam.org/journals/pdf/stylemanual.pdf :slightly_smiling_face:

Christoph, your patch for the number field did not work as you told me it should. Here is what you gave me to use (replacement):
\begin{year}\year\end{year}\begin{volume}, \volume\end{volume}, \begin{number},\number\end{number} \begin{pages}, \format[FormatPagesForHTML]{\pages} \end{pages}

Try it again in the latest development version:

Remember to make a backup of your library.

I had

reinstalled the latest windows release provided at JabRef’s home page and this was the result!

This image was taken at 2020-11-09 20:06

The number is obvoiusly only displayed when it’s filled. As soon as you enter something the preview updates.

Of course this is obvious. But, as you should be aware that I can only attach one file to a message it is somewhat awkward to send the before and after images unless they are merged into a single file. Here is the after “entering a number in the number field”. Again, your patch that you sent earlier does not work IMHO. I am open to other suggestions on this issue and I would like to know how one can use “Other fields” in 5.1.

you need to login into the forum to add attachments.

I give up on this forum :slightly_frowning_face:-- I thought the developers could provide the help I need; but, alas I was wrong. I have wasted too much of my time and the time of Christoph and Oliver. I will try to create a small python program that will modify my BibTex files (over 1200 entries) to be compatible with 5.1 and/or 5.2. I hope that others who have older versions of JabRef will be more careful than I, before they upgrade :wink: