Journal title problems

Two big problems with journal titles under version 5.1. First, switching between full and abbreviated title is not a “toggle”–it’s one way, from full to abbreviated, to even more abbreviated, with no way back (^ alt shift A fails) other than Edit / undo (which only works within the current session). Second, biblatex may be just wonderful, but my bib file with > 4k entries is in bibtex because most of them are from pubmed. It’s a real pain that (1) opening that file with 5.1 sticks the journal title way back on the “Other fields” tab (I can’t figure out how to get 5.1 to treat it as a bibtex file, or how to convert it to biblatex), and (2) even if I could, in my line of work most new entries are going to be from pubmed, therefore in bibtex format for the forseeable future. Do I just have to go back to 4.x? (which is tempting because 4.x presents web search results in a much more convenient format than 5.1’s awkwardly verbose, unsorted and unsortable form, but that’s another problem)

Are you sure you are talking about JabRef 5.1? The current version is 5.11. That’s 10 releases further. If you have a look at the changelog, you will see what has changed since then. I would suggest to give the newest version a try and check if your problem has already been fixed.

(Don’t forget to create backups of your libraries before you upgrade.)

I must be missing something. After switching to a different OS with 5.10 installed, I see the same problems with my existing bib (bibtex) file, regardless of whether default library mode is BiBTeX or biblatex. Converting bibtex to biblatex via the GUI or command line doesn’t seem to be a feature. It’s clear that JabRef has improved a lot since 4.x, but I’m getting the sense that if I want “Required fields” to show journal titles and publication dates of the references in my most important library, I may be stuck with 4.x–unless I commit to revising of this big file and manually tweaking most future additions, but that’s not going to happen.

Displaying empty Journaltitle and Date fields on the “Required fields” tab when Journal and Year data exist and are relegated to “Other fields” is a big usability issue that 5.11’s changelog doesn’t address.


first of all the behavior regarding required/optinal fields depends on two things
a) The library mode
b) the entry itself - which fields are present

As a solution for your:
Change the library to BibTeX mode
Convert your entries to BibTeX using the Cleanup “Convert biblatex to bibtex”

This is what the entry editor looks like in BibTeX mode for a new article.

which is tempting because 4.x presents web search results in a much more convenient format than 5.1’s awkwardly verbose, unsorted and unsortable form, but that’s another problem)

Thanks for your feeback, We are always working on improving the user experience.
Can you elaborate a bit more what you think can be improved?

Thanks again for your prompt reply.

That’s exactly what I want. Starting with a blank slate–JabRef 5.10, default library mode BibTeX–I clicked on File / New library, then Library / New entry, and saw exactly the same fields in the Required fields page. So far, so good.

However, what happens if I open an existing file that contains only BibTeX article entries (each entry in the source file has Journal and Year data, and no entry has a Journaltitle or Date datum)? Result: no “Journal” or “Year” field on any entry’s Required fields page. Instead, those data appear on the “Other fields” page, and the Required fields page has “Journaltitle” and “Date” fields, which are empty.

And of course if I try to use Cleanup to “Convert to BibTex format”, up pops the message “No entry needed a clean up”. And the empty “Journaltitle” and “Date” fields are still displayed in the Required fields pages, even though the default library mode is BibTeX, all entries have Journal and Year data, and no entry has a Journaltitle or Date datum.

The UI for presentation/selection of web search results is a very different topic that I will defer to a different thread.

When you open the file, does it say biblatex for the bibdatabase mode in the library settings? (right click on tab)

Aha. A very interesting and informative question. Before seeing your latest reply, I had done a little experiment: I copied a block of entries from a small bib file that JabRef was treating as a biblatex file, and pasted it into a new, empty BibTeX file that was created by JabRef. For each entry in the old bib file, the “Required fields” page showed Journaltitle and Date, but the new file’s “Required fields” page showed Journal and Year. Comparing the two files with diff revealed this in the old file
@Comment{jabref-meta: databaseType:biblatex;}
and this in the new file
@Comment{jabref-meta: databaseType:bibtex;}

grep jabref-meta *bib
on a bunch of other files, and manually editing the databaseType declaration, confirmed that databaseType controlled whether JabRef displayed Journaltitle and Date, or Journal and Year.

I have been using JabRef for well over 10 years and didn’t know this.

Nor did I know about the GUI interface for specifying database type.
Clicking on Library / Library properties brings up a “Library properties” panel which reports whether JabRef will treat the library as bibtex or biblatex, and provides a way to switch between these two options (but it doesn’t actually change any of the data in the bib file). If a library is being treated as biblatex, selecting BibTeX and then clicking on Apply doesn’t do anything to the “Required fields” displayed by clicking on any Article entry. However, an asterisk appears in the library’s tab indicating that something has changed (and that something is the metadata that tells JabRef how to interpret the data). In order to see the effect on the user interface, one must first save and close the library, then reopen it. After that, “Required fields” no longer shows Journaltitle or Date fields–instead, it now shows Journal and Year fields.

I suppose some or all of this is documented somewhere, but somehow I haven’t stumbled across that. In any case, I can now solve my problem. Many thanks!

1 Like

Thank you so much for your reply. You raise a good point.

I think the docs here could need an improvement