Customize export format in JabREF

Hi all,

Basically I’m totally bad with coding (sorry for that and I did not understand the help on the customized export layout …) but I want to export my jabref library into a csv file but with customized format as the default format does not fit what I want to do (i.e. importing the references within a mySQL database to link data to references, my engineer asks me for a specific format).

What I need is : authors, title, year, journal, volume, page and label-endnote and that’s it. No need to have the abstract, no need to have the reference cited and all other informations in the default format.

Does someone can help me ?
Thanks in advance

Cheers

Sébastien

Hello Sébastien,
I am not sure what you call the “default format”, but, to me, it looks like the information can be set in the required format without programming: first, export your library in CSV format, and then remove/reorder the various columns in a spreadsheet.
For the export: File → Export → Export all entries. Then, type in a file name, select the format OpenOffice/LibreOffice CSV, and press Save.

thanks a lot.

Of course I have tried it but the generated csv file is quite spurious as each reference is not represented by a single row, some fields such as the cited references one appears on multiple lines which makes the csv file not operational.
So I guess that reducing the number of fields in the export should solve this issue.
In addition the field “label-endnote” is not exported by the default procedure you mentioned.

Cheers

Since I have no cited references in my library, I do not have this issue of multiple lines. Maybe you could remove this information on a copy of your library, and then export it?

The OpenOffice/LibreOffice CSV export filter does not involve much programming. You will find the filter here: jabref/src/main/resources/resource/layout/openoffice at main · JabRef/jabref · GitHub
The file openoffice-csv.begin.layout is just the CSV file header.
The openoffice-csv.layout sets the actual export format. If you had ,“\label-endnote” to it, you should get it in your exported file.

To use your customized export format, go to Options → Preferences, and then “Custom export formats”. Note that the first section of Custom export filters - JabRef needed some updating; it should be OK now.

Thanks a lot … I’m pretty successful thanks to your help.

I have customized the .layout file with the required information and now the .csv file is OK (one row per reference).
However, I have added “\Label-endnote” in the file ans in the .csv file I do not have the label which is supposed to be something like B101 for each reference but only -label in all the rows. I have tried with and without the comma, same thing. In Jabber, the fiels Label-endnote appears in the “other field” menu for each reference and is well called “Label-endnote”.

Do you what could happen with this field ?

Cheers

I wonder if the dash is not interpretated by JabRef as a special character…
Maybe you could rename the field into something like “Labelendnote”? (Select your entries, Edit → Automatic Field editor, tab “Rename field”).

It works perfectly now !!

Thank you very much for your help I have my .csv file as I want !

Cheers

Sébastien

You are welcome!

JabRef is helping you on a regular basis? Please, find a way of giving back.

@sdev Took me a while to find this, but I remembered that others had a similar issue and there was a workaround/solution as well for allowing dashes