Fulltext download configuration

The fulltext search (magnifier glas in the General tab of an entry) will download the pdf into a unique directory to the entry. I want to change this behaviour together with the pdf naming convention.

I would like to have all my pdfs in one directory and named as <citation_key>.pdf. How can I achieve this?

Please vote if you support this proposal:

  • I would like to have this feature, too!
  • I don’t care.

0 voters

The fulltext download adhers to the file directoy and filename pattern from the options.
If you have a general file directory specified in the preferences all files will be downloaded to that folder,

The help covers that topic:

I was aware of that help page, but even after reading it again, I do not find where can I specify the downloaded filename. I’ve found only an option to select the download directory and there is an option for automatic linking an existing file based on a pattern.

You mentioned “filename pattern”, but I did not spotted it in the help. In which paragraph is it described? Is there any way I can define the downloaded filename?

Yeah, seems missing in the help.
It’s located under imporrt in the setitngs.
The file name format pattern defines how the file name for linked files is build. The pattern follows the cite key syntax. It’s then calulated for each entry. The sane for the fiel directory pattern, e.g. you could have a file directory pattern entrytpye and JabRef would then download articles in the
/article/ directory and so on.
And the files itself will be named according to the other patten. Sounds compicated but is actually pretty fleible for adapting

Great, thanks! That answers the filename part, but I do not know how to put all the downloaded pdfs into one directory. I want a simple, flat hierarchy without additional directories. In the import tab I can only define a pattern for the directory, but I can not disable it. If I leave the “file directory pattern” empty, then jabref uses a predefined default setting. Can I overcome this somehow?


  1. Set a main fIle directory in Settings -> File , this directory will be used globally for all files across all libraries
  2. Uncheck the “Store relative to library file” (If this is checked it takes precendence over all other dirs)
  3. Set file dir pattern under import to empty

That should work.

I am not able to figure it out. I set the File directory pattern empty, because I do not want any sub-directory, and I want all files to be downloaded into the File --> Main file directory (right under External file links). The fulltext is now <citation_key>/<citation_key>.pdf with this configuration.

In JabRef 5.1 this should work. I think there was a bug in a previous version.

Maybe it should, but it does not in my case:

JabRef 5.1–2020-06-09–595f085
Linux 4.15.0-117-generic amd64
Java 14.0.1

Could you please give a concrete example. e.g how your folder configuration looks like (e.g. library/user specific folder and how the general file directory configurations look like (preferences) and also how the patterns you used and the bibtex entry.

That would help me to test the issue