Jabref 5.10 not allowing citations to be added into sub-groups with right-click?


Upgraded to Jabref 5.10 last week, and today tried to add a citation into the database and then link it or categorize it in a sub-group, which previously I could do by right clicking on the groups line item and then “add selected items to group” . . . .

Today, multiple attempts to do that have failed, right-clicking moves to that sub-group and nothing gets added into the group . . . ??? This seems to be a significant issue as far as maintaining and adding items into a data base??

Running Jabref in Pop_OS! system. Please advise.

Jabref says it is “up to date” . . . and yet this problem of not being able to add refs into groups continues unabated . . . .

Has something been purposefully changed to do this operation or something got lost in the jump up to 5.10???

Sorry for the late reply. You are completely right and unfortunately seemingly found a regression.
I can reproduce this with JabRef 5.10 and also with the newest development version on Windows 10.

Would you mind opening an issue at JabRef’s Github repository for this?

Workaround for now: Select entries via left-click and drag and drop them into the group.

1 Like

Thanks for the reply and the hint . . . the drag and drop did work. I went to the bug report site and tried to file the bug report, but I don’t have time right now to mess with the devel version, I didn’t click either option and I guess it isn’t letting me post the bug report until I do??

Should I just click one of them to get it up in the queue?? Or, do it the right way . . . it might be a few days until I have time to play with upgrading to devel . . . .

OK, I just checked the two boxes declaring I tested the devel . . . without actually doing that. : - ) That posted the bug report.

" Problems adding citations to groups in 5.10 via right-click, as we could before #10404 "

Using Jabref today . . . problem is still persisting . . . checking updates says, “Jabref is up to date”??

Yes, the issue is still open. It’s not yet fixed.
Please keep in mind that we are all working in our leisure time at JabRef for free and therefore it may take some time until it’s fixed.