Jabref 5.10 not allowing citations to be added into sub-groups with right-click?

Still having this issue of intermittent working and then not working of the right click on sub-group to add citation. It works a few times then right-clicking changes to the sub-group . . . not adding the citation. Possibly losing the citation for further addition to sub-groups . . . .

Continuing saga . . . intermittent misbehavior, sometimes adding citation to sub-group, sometimes not . . . hard to find consistent issue. Monday is my research day . . . have not found the problems as getting better.

Might try rolling back to 5.9 and see if that gets overall better functioning . . . ???

Hm, I can only say that it’s working as expected when your right click on the group, once you left click you will select the current group.
We recently also fixed the scrolling, so that might also be an issue here, please try again the latest version.

Tip: If you define a color for your group, you can easily see the colored bar at the side of the entry to see if it worked

OK, I’ll check the latest package and see how that goes.

With the 5.11+ I have now, it worked for a couple of citations, then it didn’t add the citation and the drop down menu box would hang open . . . then I saved the library, and then it seemed to work again with the right click. Before I saved the two items I did the drag n drop to move it, but that didn’t seem to work properly . . . .

Back atcha when I’ve tried the latest offering . . . few days to get the time for it I believe.

OK, the 5.12 version is “better” than the 11 . . . I wanted to say it was “perfect” . . . but there were some right-click glitches . . . with adding to subgroups.

But the download retrieval was back on par . . . .

1 Like

Thanks for the feedback! We will try if we can make the selection process a bit better.

This one is in the ball park . . . the remaining problem is that again, intermittently, the right-clicking drop down menu would “hang” or remain dropped down after clicking “add to subgroup” . . . obscuring the sub-group count number, so you can’t tell if it added it or not–visually. It seemed like mostly it was doing the right action to make the addition to the group, but the menu was hanging out in the way, to coin a phrase. The problem repeated itself enough times to mention it. As before if all we would be doing is adding one citation and then closing the app, all would probably be well, seemed like after the first few clean operatioins to ad citation then it started to get “Sid-like.”

otherwise, very much better than the two previous iteration . . . . : - )))))

1 Like