JabRef stops at 50 entries

I use JabRef an TexStudio. Until yesterday it worked fine, downloaded the citation from webpages (like wiley etc.) and imported it in my jabreffile. Used \cite{ref} in Text and all was good.

By today things got wierd. I exceeded 50 entries (now 53) in my JabRef and was compilig the document as usual. All worked fine, but then a strange warning came up: “Citation ‘ref’ on page xyz undefined” This happened to ALL citations I added. Including self written, downloaded an even old ones (just changed the page for testing).
I have literally no f***n clue whats wrong… Even google was like: I have no clue either.

So guy, I need your help:
Has anyone any clues whats wrong?

Thanks in advance!

Edit 1: Forgot to say: Yes, i saved the Jabref file before compiling. And funfact: If i do \cite{}, Texstudio even DOES show the entry i’d like to use and all the properties.

Edit 2: restart does not solve the problem

Edit 3: Here is a picture of the problem:


I guess you are using bibtex and not biblatex.
JabRef uses unicode for such things as accents or other characters. I suggest trying to do a right click on the author field -> Convert -> Unicode to Latex. This will escape the critical unicode chars in a latex compatible way


TexStudio says the Bibliography used is BibLaTex and in jabref it’s UTF-8 in biblatex mode.
Should i change UTF-8 to UTF-32 or US_ASCII

tried this entry (and deletet de ba^ci´c one) instead, does not work either

BUT: i installed TexStudio, MikTex and Jabref on my Laptop and just copy pasted all files. It works, even the bacic with the strange letters! So it seems to be a problem in some config stuff

In TeXstudio, there is an option to delete the Temporary files. Maybe that helps.
Or there is a difference in the configuration

well, now all citations are gone :joy: :sob:

i’m compiling: PdfLaTeX, BibTex, PdfLaTeX, PdfLaTeX

also tried it two times…

Since your problem does not look related to JabRef, I think you should ask on a TeXstudio forum. You will get better answers because there will be more specialists.

You are using biblatex, so you need to run biber

I copied all corefiles (.bib, the .tex and all pictures) to my laptop and compiled with pdflatex once. It works. Jabref and Texstudio are at factory settings.
Then i resetted the settings from TexStudio at my PC. Nothing.
Then jabref. Again: nothing.
Deleted all temporal files so that just corefiles remained: nope
Edited the comipler: pdflatex, biber, pdflatex, pdflatex: narp
pdflatex, bibtex, pdflatex, pdflatex: Нет
Edited standar Bibprogram from Bibtex to biber: big nope
Copied the files back from my laptop and used them on PC with just pdflatex and bibtex as bibprogram: joke’s on you: it finally works! Dunno what was wrong, basically it was the same as copying the corefiles but hey, i won’t complain.

If this’ll ever happen again, I’m doing the workaround: typing on my PC, save, export data to Laptop and compile there… If that’s how the cookie crumbles…

I also asked in a Texstudio forum, the answer they give was “Hey, sounds like a jabref thingy, ask in a jabref forum”… XD)


that sounds odds. Maybe you have slightly different versions of the programs?