Problem with special characters in references

Hi all,

I am using JabRef to insert library on .tex files. Encoding in JabRef is UTF-8 and so is in .tex files.
Some of the references contain special characters. I get the followign symbols in .bib file:
á etc

I try to manually correct these issues, so that:
ĂŻ → {"\i}
â€� → -
á → {'i} etc

Once I do this and run .tex file, everything is OK. But if I add any new reference from the JabRef interface and save it, characters become again unusual and I get the following error when running the .tex file: “! Package inputenc Error: Invalid UTF-8 byte sequence.”

What can I do so that JabRef is properly saving the .bib files? Additionally, is there any way for the references that I have already modified, not to change back after adding or modifying a reference?

Thanks in advance.


This sounds like a problem with the Latex2Unicode conversion. There has been reported a similar bug.
Generally, you can check your library preferences, if you have any save actions defined. So in that case JabRef should not convert your changes.

Do you have a sample reference? For a simliar buf report see here

Thank you! Finally, the problem was solved! Original encoding for my tex files was windows-1250. I changed it to UTF-8 but still had the problem because I hadn’t restarted the application. Once, I closed and opened it again, it worked properly.

1 Like