New release seems to break paste into source field on mac

After upgrading to 5.1 on a mac running Catalina, I can no longer paste into the “biblatex source” field.

There is a similar issue in the bug tracker:
And there is a (temporary) solution to circumvent it.
I hope this help.

Thanks for the reply. I did install 5.2, but it doesn’t seem to help, unfortunately.

@Jonathan_Lilly I am a mac user myself and the latest 5.2 fixed it for me.
How do you paste? Using the shortcout cmd+v ?

Ok, I see. I can now paste over the whole entry if it is selected. So, that is a good enough workaround. However, I can’t place the cursor in the bibtex source window and paste in a particular location as I used to, nor select all text in the bibtex source and paste over it. And I’ve tried with both drop-down menu or command-V.

@Jonathan_Lilly I’m on Catalina 10.15.6 and using the latest JabRef version from
For me pasting in the bibtex source code works fine, also placing the cursor at some point and pasting in between works.

Edit// I used cmd+c and cmd+v to copy/paste