Please help me with my problem with 'Look up full text documents' utility

Recently the fuction Look up full text documents of my JabRef always failed with the message Full text document download failed for entry XXXX. However, if I open the URL link, it shows that I have the accesss to download the pdf file on the web page. Could you please tell me what is the possible problem here? How can I fix this problem?
Any help would be much appreciated!


first of all it would be nice if you could provide some details about the full text you are trying to download and some details on your system, e.g. operating system and if you try the fulltext download from within an university network or from outside
A link or name etc and the bibtext citation would be nice.

Did you check if there are possible entries in the Error log?
Help -> Show Error Console


I am very sorry I replied so late.
I have tried a lot of entries in my database. They all seem have the same problem Full text document download failed for entry XXXX.
I also tried both on Windows7 and Ubuntu14.04LTS platforms with recent version of JabRef, including 3.8, 3.8.1 and 3.8.2. My computer is inside an university network.
I choose the bibtex key of one entry in my database, that is:
@Article{Friedland2017_NIaMiPRSBBIwMaA.391.10, author = {Friedland, E.}, title = {Investigation of amorphization energies for heavy ion implants into silicon carbide at depths far beyond the projected ranges}, journal = {Nuclear Instruments and Methods in Physics Research Section B: Beam Interactions with Materials and Atoms}, year = {2017}, volume = {391}, pages = {10--13}, abstract = {At ion energies with inelastic stopping powers less than a few keV/nm, radiation damage is thought to be due to atomic displacements by elastic collisions only. However, it is well known that inelastic processes and non-linear effects due to defect interaction within collision cascades can significantly increase or decrease damage efficiencies. The importance of these processes changes significantly along the ion trajectory and becomes negligible at some distance beyond the projected range, where damage is mainly caused by slowly moving secondary recoils. Hence, in this region amorphization energies should become independent of the ion type and only reflect the properties of the target lattice. To investigate this, damage profiles were obtained from α-particle channeling spectra of 6H-SiC wafers implanted at room temperature with ions in the mass range 84 ⩽ M ⩽ 133, employing the computer code DICADA. An average amorphization dose of (0.7 ± 0.2) dpa and critical damage energy of (17 ± 6) eV/atom are obtained from TRIM simulations at the experimentally observed boundary positions of the amorphous zones.}, doi = {10.1016/j.nimb.2016.11.025}, groups = {RSS}, issn = {0168-583X}, keywords = {Amorphization energies, Ion implantations, Silicon carbide}, owner = {Wenqiang}, timestamp = {2016.12.02}, url = {}, urldate = {2016-12-02}, }
I can download the pdf file of this article on the url However, it pops up with an error if I use 'Look up full text documents` function.

I cannot understand the log message. I copied them as the following:
10:25:52.456 [AWT-EventQueue-0] WARN net.sf.jabref.JabRefGUI - There seem to be problems with OpenJDK and the default GTK Look&Feel. Using Metal L&F instead. Change to another L&F with caution. 10:25:52.521 [AWT-EventQueue-0] INFO net.sf.jabref.logic.importer.OpenDatabase - Opening: /home/wenqiang/MEGA/Jabref/radiation_damage/radiation_damage.bib 10:25:53.127 [AWT-EventQueue-0] INFO net.sf.jabref.logic.importer.OpenDatabase - Opening: /home/wenqiang/MEGA/Jabref/others/others.bib 10:25:53.163 [AWT-EventQueue-0] INFO net.sf.jabref.logic.importer.OpenDatabase - Opening: /home/wenqiang/MEGA/Jabref/shii/shii.bib 10:25:53.180 [AWT-EventQueue-0] INFO net.sf.jabref.logic.importer.OpenDatabase - Opening: /home/wenqiang/MEGA/Jabref/nanowire_md/nanowire_md.bib 10:25:53.203 [AWT-EventQueue-0] INFO net.sf.jabref.logic.importer.OpenDatabase - Opening: /home/wenqiang/MEGA/Jabref/manual/manual.bib 10:25:53.218 [AWT-EventQueue-0] INFO net.sf.jabref.logic.importer.OpenDatabase - Opening: /home/wenqiang/MEGA/Jabref/myself/myself.bib 10:26:54.096 [Spin-4] INFO net.sf.jabref.logic.importer.fetcher.ScienceDirect - Fulltext PDF found @ ScienceDirect. 10:29:56.918 [Spin-5] INFO net.sf.jabref.logic.importer.fetcher.ScienceDirect - Fulltext PDF found @ ScienceDirect. 10:38:21.632 [Spin-6] INFO net.sf.jabref.logic.importer.fetcher.ScienceDirect - Fulltext PDF found @ ScienceDirect.

I cannot fix my problem. Could you please help me more?
Thanks in advance!


thanks for the information. I could reproduce that issue with JabRef 3.8.2 on univeristy network.
I think it has to do with the ScienceDirect Fetcher which does currently not work.
But it is strange that in the log it claims to have found the fulltext.

I will investigate that issue.
In the meantime you cann manually download the pdf and link it with JabRef (either by moving the downloaded PDF with Drag & Drop to the entry or in the Entry Editor by General-> Download from url where you can provide an URL for download=


Thank you very much for your answer!
As you know I have configured the Filename format pattern, it is much easier to use this function as I do not need to rename the PDF file. I feel that this function is very very convenient.
Your suggestion about Download from url is very helpful! I found that the downloaded PDF file will be renamed automatically. I am wondering whether the format pattern is the same as Look up full text documents?

Best Regards


yes I think so. You can also run Cleanup -> Rename files to filename
pattern on multiple (or all) entries. That will rename the linked files.
Look up fulltext does not always work (although it might be accessible) ,
as we only have a few sites we check for the file and each site has a
different structure.

Best regards

The Cleanup -> Rename function is wonderful. Thanks very much for your hint!
Thanks to your help, I can use Download from URL instead.
I think Look up full text document is the most convenient way to download the PDF file of an entry among all the methods. Although I do not know the mechanism of the function, I understand it is very hard to develop it.
Thanks a lot for all your answers!

Best regards