The function of copy linked files to folder


I just upgraded from Jabref 4.3.1 to 5.0.
I found that the function of copy the linked file of a selected entry to folder disappears. I could find it either in the File->copy linked file or via right-click menu.

Is there any plan to get this function back in 5.0?
Thank you very much.

You can either use the cleanup operation (better for batch movements) or right-click the file in the “General” tab of the entry editor.

1 Like

Thank you very much.

Finally, I find the “copy linked files to folder…” menu which located in Tools.

I need this function just because I want to share the linked files with others. I organized the entries by group. But the linked files are organized by the Journal. It will be more convenient to share many papers under the same group.

I will try the clean up operation.

1 Like

@QuantumGuy You can let JabRef automatically organize your files.
Under Preferences -> Import you can define the Linked file name conenventions.
If you enter [groups:(unknown)] as a file directory pattern JabRef will put the linked files into a folder named after the group(s). If an entry is part of multiple groups, the group folder name is a comma separated list of group names.
If you then use the cleanup operations “Move files to file directory” JabRef will move the linked files to the group.
Newly downloaded paper will then be automatically moved into that directory,.

@Siedlerchr Thank you very much for your advice. This is a nice way of the managing the literature. I will try this way.

It sounds like a very good function of JabRef, however, it does not work for me, I enter [groups:(unknown)] as a file directory pattern in the Preferences -> Import. Then cleanup entries and nothing happens (the attached pdf file in still in the primary file directory)

for me this works fine. Did you check the checkboxes “Move files to file directory” in the cleanup?

You can also test right click on the file in General -> Move file to file directory

Wow, It works thanks for your help and stay healthy!

1 Like

Apologies for resurrecting this old thread but is there a way how to implement this in the existing automated link files sections? What I have in mind are the following places:

  • [Preferences] > Linked Files > File Directory Pattern
  • [Library Properties] > General File Directory / User-specific File Directory

What I want to achieve is that under a unified ‘root’ folder [PDF], the subsequent subfolders will follow the names of the respective group(s) the publication is incorporated, e.g. [PDF]/groupA/1.pdf

I tried the method suggested above, but I could not make it working. Jabref v5.3 shows me an error. Any help would be more than welcome!

If you are on windows and use the NTFS filesystem, then don’t use special characters in folder- and file-names. / / is likely one of or THE Problem. If you use another Operating System like Linux, this might not be relevant to your case. Most Linux distributions use EXT4.

See: Filename - Wikipedia and Comparison of file systems - Wikipedia

Could you post the error?


Obviously the error is not with the forward/backslash but with the column. I tried [groups] on it own as well, to no avail…

PS: with v5.3 there is no issue with the forward/backslash, there used to be but not anymore

Sorry, i said something foolish. My initial impression was that you tried to create a folder hirarchy from within jabref by inserting special names in the ‘Linked file name conventions’ section.

I tried to reproduce what you do on

JabRef 5.4–2021-08-21–644e48d
Windows 10 10.0 amd64
Java 16.0.2
JavaFX 16+8

Cleanup preferences:


When i use these options, nothing happens. entries don’t move and a pdf folder is not created:

When i use the following option instead of pdfs\[groups:(unknown)], on first usage of cleanup entries, it only changes the name of the pdf files, on second usage it moves the pdf files to folder test1:

I then realised that the pdf files in the bib entry still link to the original folder instead of test1. So i ticked the option image
in cleanup entries which solved that problem, but since then i can’t move it back to the original folder even when i enter the original folder in Main file directory and that very folder shows up in cleanup entries.

I did try a few other things, but I have never encountered any error messages. Maybe because i use the Windows edition and you use another one?

Could you also post your Jabref version + Operating system? You can find this in Help>About JabRef

1 Like

Hm, this is weird, as I use the following version:

JabRef 5.3–2021-07-05–50c96a2
Windows 10 10.0 amd64
Java 16.0.1
JavaFX 16+8

I do not use a cleanup part, I just right-click on the PDF file in jabref Entry editor File section, and I select “Move file to file directory”

Actually, please ignore my previous comment. I made it working, for those looking for the solution, the following needs to be set:

  1. Preferences > Linked Files

  2. Library > Library Properties (set for each bib file individually)

These 2 settings together put the imported files under …PDFs/groupname/bibtexkey.pdf


Thank you @doffactory for posting your solution. Nice to know that it worked out for you.

As a reminder to myself and others, the following issue is still standing:

I might play around with that at another time, but not now. Maybe i just do something wrong