Two references drop journal title when piped to lyx

(Rich Shepard) #1

This issue is new with the document I’m writing and I’m trying to isolate the issue to JabRef or LyX.
I run jabref-3.8.2 on my 32-bit desktop because the 4.x series requires openofx and that’s available for only 64-bit processors running Slackware-14.2. This issue occurs with only two references (had been one until just now). both by the same author. JabRef and LyX are configured to use bibtex, not biblates. With these references the journal name is not piped to the lyx document. JabRef shows it as ‘journaltitle’ rather than ‘journal’, but that holds for all articles. When I look at the citation in the lyx document the journal title is not present. I’ve re-entered these articles and that makes no difference. I’m open to all thoughts.

(Rich Shepard) #2

Found and fixed the problem; it was in the jabrefdb.bib file.

Somehow, 65 of 620 @Article records had the publication key set to the biblatex syntax, journaltitle, rather than the bibtex syntax of journal. A quick emacs search-and-replace made all the changes and the problem has gone away.

(Christoph) #3


since a while we also have a cleanup operation from biblatex to bibtex in case you need it.
It should be included in version 4.1


(Rich Shepard) #4


Unfortuately, I cannot upgrade to the 4.x versions because the required
openjfx is not available for 32-bit processors on Slackware and apparently
is difficult to build from source.

I had always had jabref configured for bibtex but the upgrade to 3.2.8
changed that and it took me a while to notice.


(Christoph) #5


you could try the Oracle Java installation with a recent Java 8 version (java 9 is currently not supported). It should be still available for 32 Bit.

(Rich Shepard) #6


I run openjdk-8u151_b12. It’s the openjfx that’s available for only 64-bit

Now I know that when I corrected JabRef to use bibtex rather than than
biblatex it did not change the field name from journaltitle to journal. I’ve
looked at all the field options in ‘preferences’ and they all say 'journal’
so … I just found ‘journaltitle’ in
~/.java/.userPrefs/net/sf/jabref/prefs.xml and in
~/.java/.userPrefs/net/sf/jabref/customizeBibtexTypes/prefs.xml and changed
both to ‘journal.’

That should do the job.