Error in connection to Ubuntu 20 L.O. 7.1 even if document is connected

Hello,
I had a problem with the connection between JabRef and LibreOffice Writer which I resolved by re-installing L.O.
Now I am working on a new machine and I had the same problem. I re-installed LO so that now I am running LibreOffice 7.1.2.2 10(Build:2), which I installed using PPA. I connected LO to /usr/lib/libreoffice/program and the connection does not give any trouble. Then I connected to the open writer document and also this goe without problem. But when I try to cite I get the error “not connected to any Writer document”.
How can I solve it?
Thanks

Hi
thanks for the report. I just tested the latest dev version of JabRef under mac osx with LO 7.1.2.2 and this works fine.

Can you test the latest dev version?
index - powered by h5ai v0.29.0 (https://larsjung.de/h5ai/) (you can use the deb or the portable)
Remember to make a backup of your library before testing

Thank you. I remove the previous version of jabref and installed the one you suggested. I then set the manual connection to /usr/lib/libreoffice/program but I got the error attached. To note that Writer was open as you can see in the background. I am using JR 5.2 on another two ubuntu 20 machines. Why do I get an error here? Would Java version matter? here I have

$ java --version
openjdk 11.0.10 2021-01-19
OpenJDK Runtime Environment (build 11.0.10+9-Ubuntu-0ubuntu1.20.04)
OpenJDK 64-Bit Server VM (build 11.0.10+9-Ubuntu-0ubuntu1.20.04, mixed mode, sharing)

Regards,
Luigi

Hm this is odd, no idea.

@LyzardKing Can you reproduce the issue?

I can’t reproduce this issue…
Should the path not be /usr/lib/libreoffice?

If I use /usr/lib/libreoffice only, I get a connection error straight away. but I am getting it also with /usr/lib/libreoffice/program…

I reinstalled from software manager but I still getting:

java.io.IOException: (Not all) required Open Office Jars were found inside installation path. Searched for [unoil.jar, jurt.jar, juh.jar, ridl.jar] in /usr/lib/libreoffice
	at org.jabref@5.2.60000/org.jabref.gui.openoffice.OpenOfficePanel.findOpenOfficeJars(Unknown Source)
	at org.jabref@5.2.60000/org.jabref.gui.openoffice.OpenOfficePanel$2.call(Unknown Source)
	at org.jabref@5.2.60000/org.jabref.gui.openoffice.OpenOfficePanel$2.call(Unknown Source)
	at org.jabref.merged.module@5.2.60000/javafx.concurrent.Task$TaskCallable.call(Unknown Source)
	at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
	at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.base/java.lang.Thread.run(Unknown Source)

If I try to navigate inside /usr/ I get the error of protected folder…

I tried to install version 3.8.2 (which is very nice, by the way) from software manager. I get the error:


Looks the problem is popping out: I have no option for Java in LO. I tried to install it with sudo apt install default-jre libreoffice-java-common but

$ sudo apt install default-jre libreoffice-java-common
Reading package lists... Done
Building dependency tree       
Reading state information... Done
default-jre is already the newest version (2:1.11-72).
libreoffice-java-common is already the newest version (1:7.1.2~rc2-0ubuntu0.20.04.1~lo3).
libreoffice-java-common set to manually installed.
The following packages were automatically installed and are no longer required:
  libboost-regex1.71.0 libboost-serialization1.71.0 libboost-system1.71.0
  libjuh-java libjurt-java libridl-java
Use 'sudo apt autoremove' to remove them.
0 to upgrade, 0 to newly install, 0 to remove and 21 not to upgrade.
$ sudo apt install default-jre
Reading package lists... Done
Building dependency tree       
Reading state information... Done
default-jre is already the newest version (2:1.11-72).
The following packages were automatically installed and are no longer required:
  libboost-regex1.71.0 libboost-serialization1.71.0 libboost-system1.71.0
  libjuh-java libjurt-java libridl-java
Use 'sudo apt autoremove' to remove them.
0 to upgrade, 0 to newly install, 0 to remove and 21 not to upgrade.
$ sudo apt install libreoffice-java-common
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libreoffice-java-common is already the newest version (1:7.1.2~rc2-0ubuntu0.20.04.1~lo3).
The following packages were automatically installed and are no longer required:
  libboost-regex1.71.0 libboost-serialization1.71.0 libboost-system1.71.0
  libjuh-java libjurt-java libridl-java
Use 'sudo apt autoremove' to remove them.
0 to upgrade, 0 to newly install, 0 to remove and 21 not to upgrade.

The java connection is actually on Advanced:


but even if I manually locate /snap/libreoffice/208/usr/lib/jvm/java-11-opendk-amd64 I get no connection. I located unoil.jar on:

$ locate unoil.jar
/snap/libreoffice/207/lib/libreoffice/program/classes/unoil.jar
/snap/libreoffice/208/lib/libreoffice/program/classes/unoil.jar
/usr/lib/libreoffice/program/classes/unoil.jar
/usr/share/java/unoil.jar

but none worked (unless is /usr/lib/openoffice/program/soffice that is wrong.
Does any of it help?
Thanks

Hm… odd.
You need both the deb variant of JabRef and LO. Can you try to uninstall the snap variant of LO?

Actually, I noticed I have two versions installed: 7.1.3.2 and 7.1.2.2. How can I remove the snap one? Tx

This might be the issue then,

sudo snap remove libreoffice 

I removed it, now I have
Version: 7.1.2.2 / LibreOffice Community
Build ID: 10(Build:2)
CPU threads: 16; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-GB (en_GB.UTF-8); UI: en-US
Ubuntu package version: 1:7.1.2~rc2-0ubuntu0.20.04.1~lo3
Calc: threaded
I am running both Ubuntu and Oracle Java but the connection is still wrong:


where
$ locate unoil.jar
/usr/lib/libreoffice/program/classes/unoil.jar
/usr/share/java/unoil.jar
do not work either manually…

Okay, so the following should work now. You only need to set the path to the executable. The jars are included in JabRf.
LO deb → check
JabRef 5.3 → check (you need at least 5.2 as there have been changes to the LO connection)

In the LO Manual connection dialog in 5.3: enter
/usr/lib/libreoffice/program/

Alternatively, you can reset your preferences, this clears any previously entered LO path.

I have version:
JabRef 3.8.2
linux 5.4.0-72-generic amd64
Java 10.0.2
When I try to set the manual connections, I get the weird message of duplication of the path.


I’ll try to update jabRef…

I think we are going in circles: I updated to JR 5.2
JabRef 5.2–2020-12-24–6a2a512
Linux 5.4.0-72-generic amd64
Java 15.0.1
but I got the same errors as before:

You need at leat 5.2 of JabRef, because there have been some fixes to make it compatible with LO 7

I installed JR 5.2 as well as Java 16 – which is now running as JRE in LO7 and still I can’t connect…