INFO org.jabref.logic.openoffice.StyleLoader - Cannot find external style file


I used a style file that is no longer accessible on my system (network drive I don’t have access to anymore). It causes JabRef to hang on opening as it attempts to load the file:
13:51:42.519 [AWT-EventQueue-1] INFO org.jabref.logic.openoffice.StyleLoader - Cannot find external style file myfile.jstyle myfile.jstyle (No such file or directory)

it is probably very simple but I cannot figure out how to prevent it to look for the file. I opened the openoffice/libreoffice plugin, and there is no link to it anymore, so I’m at a loss of to where I can delete this reference. Any insight appreciated!

Thanks a lot in advance.

You can reset the preferences using java -jar JabRef.jar -d all, see for more infos.

Thanks a lot! I tried that, unfortunately the issue doesn’t seem to be in the preferences - the problem persists (running java -jar on the same .jar still displays the same text as above, meaning it’s still looking for that file). Likely an issue with the OO connection plugin, but now that it’s part of JabRef I don’t think I can uninstall/reinstall… I have no idea where settings are kept, or I could remove them manually (re-downloading a new .jar didn’t solve the issue).
Thanks again :slight_smile:

Normally the Open Office stuff is stored in the preferences as well.
Are you using the latest JabRef version (if not, try using it from here,
I remember about having the same issue once. I hope it got fxed :wink:

As a workaround you could try creating an empty text file and rename that to myfile.jstyle

In the OO connection dialog you can then click “Select style” to open the style chooser dialog and select a new one


Sorry for the delay in answering and thanks for the suggestion! I am using the latest JabRef version (4.2-dev) and so it didn’t get fixed :slight_smile:
Your workaround worked, however, so it’s all good now even if I still have no idea where that path was stored in!

Thanks again!

Glad that the workaround helped.

Would you please create an issue at our bugtracker, so that someone can fix this.