Rmarkdown not recognizing JabRef citatation

Rmarkdown document is not recognizing the citation in the bib file created by JabRef. I can copy-paste a BibTex citation into a text file saved as name.bib file and Rmarkdown will knit it. If I copy-paste a BibTex record source created by JabRef, none of the references created by JabRef are knitted and the reference in the body of my text knits as ???

E.g. @Samonte2002 produces three question marks in the body of the text and no reference is knitted. The reference to (at)1974wheelock will knit. The reference to (at)Samonte2002 does not knit.

Any ideas?

title={Wheelock v. Heath},
booktitle={NW 2d},
number={No. 42118},
publisher={Neb: Supreme Court}

author = {Samonte, Rhea Vallente, Eichler, Evan E.},
title = {Segmental duplications and the evolution of the primate genome},
journal = {Nature Reviews Genetics},
year = {2002},
volume = {3},
number = {1},
pages = {65-72},
issn = {1471-0064},
abstract = {Initial human genome sequence analysis has revealed large segments of nearly identical sequence in particular chromosomal regions. The recent origin of these segments and their abundance (∼5 percent) has challenged investigators to elucidate their underlying mechanism and role in primate genome evolution. Although the precise fraction is unknown, some of these duplicated segments have recently been shown to be associated with rapid gene innovation and chromosomal rearrangement in the genomes of man and the great apes.},
doi = {10.1038/nrg705},
url = {https://doi.org/10.1038/nrg705}

I’ve no experience with Rmarkdown, but this sounds more like a bug on their side.

I exported the references to xml and tried to use them in MS Word. No Rmarkdown involved at all.

I get the same result.


(Attachment TestOfCode.docx is missing)

Hi Tobias:

I tried to send you an example in MS word. The result is exactly the same whether it is knitted in RMarkdown or imported as an xml file into MS Word. Word behaves the same as Rmarkdown. TheJabRef references do not work.


Do you only have problems with the Samonte2002 entry, or is this a general problem independent of the entry?


Thank you so very much for your attention to this issue.

This is my first experience with JabRef. I created the references from three sources.

Manually, Google Scholar and from PubMed.

The bib doc created in the RStudio IDE by manually copy paste of the BibTeX citations; pasted into the bib document. This method works in RMarkdown when I knit ro html. The reference also works in MS Word documents.

None of the references created in JabRef work at all. When the bib document created by JabRef is referenced in RMarkdown, the reference does not create any error in my RMarkdown document. I get three question marks in the output where the citation is placed and nothing appeared in the Reference section.

If I export the references from JabRef into xml, the xml will not attach to Word. Word produces an error warning that the xml is not a bibliographic reference. The xml will not connect at all with Word.