Unable to edit the entry preview

Hi there, I’m facing an issue which I believe to be a bug, where it seems that I am unable to edit the Customized preview style in the entry preview.
However, before submitting a bug report, I would like to ensure that I’m doing everything right.

Here the steps that I take in order to replicate this behavior:
1. Open Options > Preferences > Entry Preview and select the Customized preview style.

2. Press the Edit tab and make an arbitrary (yet valid) change. In this case, I decided to remove the <b> and </b> on line 4, to have a normal title instead of bold.

3. Switch to the Preview tab, the change is gone and the title is in bold.

4. Switch back to the Edit tab, make the same change, but this time hit Save instead.

5. Entry editor closes, dialog saying Preferences saved shows, revealing the Entry editor again shows that my changed were not saved. Going back to Options > Preferences > Entry Preview and select Customized preview style shows the preview style is again back to default.

I’m pretty sure that the changes are valid, and the mechanism which I’m using to change the preview is the one suggested in the documentation - link - so I’m not quite sure what’s going on here.
There seems to be an issue on Github which is of similar nature [#6447], however, for this user, the preview is shown properly in the preview tab, he just needs to restart JabRef for changes to take effect
Any tips?

I have just tried to reproduce the behavior you observed, to no avail. For me, it works from step 1 to step 3: the preview account for the my edits.

I am using JabRef 5.5–2022-01-10–9e3506f – Linux 4.19.0-18-amd64 amd64 – Java 16.0.2 – JavaFX 17.0.1+1 (i.e. the development version that is available at index - powered by h5ai v0.29.0 (https://larsjung.de/h5ai/) .

Which version of JabRef are you using?
Could you try with the development version, please?

Cheers

Thanks for the reply,

I’m using JabRef 5.4-1 on Manjaro running i3WM, installed from the AUR.
Kernel version is 5.4.169-1, on x64.

I can give a shot at the development version later. If I were to uninstall the stable version and install the development version I could easily revert back or would my library suffer some changes?

You could do the test using the portable version of JabRef (JabRef-5.5-portable_linux.tar.gz), so you do not need to uninstall anything: uncompress the .gz file ; launch ./JabRef/bin/JabRef ; do the test; remove the directory.

It is always a good practice to make a backup of your library, even if I do not expect any adverse effect.

I have a full system backup with Duplicati, it’s on a daily basis however, hence the question.

Anyways, with version 5.5, I have exactly the same problem as the Github issue I’ve pointed out in the first post [#6447], meaning that it only shows up after a JabRef reboot - which is already an improvement!
Interestingly, when coming back to version 5.4, the one installed system-wide, the modifications are reflected, and if I try to undo them, I can’t.

Considering I only want to change this once or twice, this is a good enough solution, although, extremely hacky!

Should I report my findings on the relevant Github issue and consider this closed, or should I do further debugging?

I suppose your initial issue was solved in the development version by Observable Preferences J (Preview) and minor refactor by calixtus · Pull Request #8370 · JabRef/jabref · GitHub .
Please, report your findings in github, that will complement the information and may help to solve the issue.